SharePoint

Gebruikersnaam wordt niet correct weergegeven

23 maart 2012

In sommige SharePoint omgevingen worden gebruikersnamen niet goed weergegeven, bijvoorbeeld:

i:0#.f|membership| en dan de gebruikersnaam.

Het probleem is bij Microsoft bekend en die geven aan dat het vooral gebeurd bij medewerkers die veranderingen maken in hun gebruikersnaam of domein.

Bijvoorbeeld:

tobyn@contoso.sharepoint.com naar tobyn@contoso.com

tobyn@contoso.sharepoint.com naar toby.nixon@contoso.sharepoint.com

Microsoft heeft aangegeven eraan te werken en dit zo snel mogelijk proberen op te lossen.
link naar: http://community.office365.com/en-us/w/sharepoint/user-name-does-not-display-correctly.aspx
Info: Een reactie op de site (zie link hierboven) geeft aan dat het mogelijk moet zijn om via onderstaande stappen:

1. Selecteer ‘SharePoint Online beheren’ als admin op https://portal.microsoftonline.com
2. Selecteer ‘Gebruikersprofielen beheren’.
3. Selecteer ‘Gebruikersgegevens beheren’.
4. Bewerk de eigenschappen van het veld ‘Naam’.
5. Bij ‘Instellingen bewerken’ kies voor ‘Gebruikers toestaan om waarden voor deze eigenschap te bewerken’
6. Klik op ‘OK’.

Echter dit blijkt bij onze omgeving niet te werken, de gebruikers kunnen hun naam nu wel wijzigen maar accountnaam waar i:0#.f|membership| voor staat niet.

In plaats van gebruik te maken van Gebruikersnaam() in InfoPath voor het opvragen van de gebruikersnaam in SharePoint maak ik gebruik van de SQL string:

subtekenreeks-na(Gebruikersnaam(), “membership|”)

Alles na ‘membership”|’ word nu weergeeft in het InfoPath formulier.

You Might Also Like

Geen reacties

Plaats een reactie